Ícone RSS Ícone Página Principal
  • Warsaw para o Itaú Internet Banking

    Publicado em 2 de setembro de 2017 omyasuda Sem comentários

    Ainda estou às voltas com o acesso ao Itaú Internet Banking no ambiente Ubuntu 17.04 64 bits.

    Um clique no botão “Instale agora” nos leva a página de download do arquivo warsaw_setup_64.deb sem maiores explicações ou alternativas.

    Prereqs

    No passado, a instalação do Guardião Itaú requeria os recursos do libnss3-tools e do libcurl3. Por via das certeza, procurei atualizar estas bibliotecas com:

    sudo apt-get update

    sudo apt-get install libnss3-tools libcurl3

    As mensagens resultantes indicam que estas bibliotecas estavam atualizadas e nada foi feito.

    Programas Ubuntu

    A instalação do arquivo baixado  warsaw_setup_64.deb usando o instalador Programas Ubuntu ( Ubuntu Software ) não teve sucesso, apesar de não apresentar mensagens de erro.

    Alternativamente, tentamos a instalação pela linha de comando, não sem antes limpar as instalações (e/ou tentativas anteriores), com

    sudo dpkg –purge warsaw

    sudo dpkg –install warsaw_setup_64.deb

    A desinstalação com purge pode parecer exagero, mas realmente encontra e retira configuração anteriores do pacote warsaw instalado. O que pode ser prudente.

    A instalação na linha de comando, apresenta as mensagens do processo de instalação. Incluindo a solicitação para sair do Mozilla Firefox para continuar com a instalação.

    Entre as mensagens durante a instalação

    Getting CA Private Key
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_BAD_DATABASE: security library: bad database.
    Notice: Trust flag u is set automatically if the private key is present.
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_BAD_DATABASE: security library: bad database.
    Notice: Trust flag u is set automatically if the private key is present.
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_UNRECOGNIZED_OID: Unrecognized Object Identifier.
    Notice: Trust flag u is set automatically if the private key is present.

    A presença destas mensagens não parecem impedir o progresso da instalação, mas causa um certo desconforto.

    Em alguns casos, ao final do processo de instalação, foi  necessário reiniciar o computador. Fato incomum para o ambiente Ubuntu.

    O acesso ao Bankline encontrou o Guardião devidamente instalado e funcionou bem no Mozilla Firefox 55.0.2 para 64bits. Mas, continua apresentando o mesmo problema nos navegadores Chrome e Chromium.

    Outras Perguntas

    1. O que acontece se ligarmos para o atendimento do Itaú pedindo ajuda com este problema? Um dia tentarei isso, mas se você já tiver experienciado isso, conte-nos!
    2. http://www.dieboldnixdorf.com.br/warsaw – O que é? O que faz? Ainda é necessário? Quando?
    3. http://www.gastecnologia.com/ – O que aconteceu com a GAS Tecnologia?
    4. Como fazer funcionar no Chrome e no Chromium? Ou outros navegadores?
    5. App Itaú no Computador – não tem para o sistemas operacionais Linux.

    Referencias:

    1. Como instalar o módulo de segurança do Banco Itaú no Linux
    2. COMO INSTALAR O GUARDIÁO ITAÚ (WARSAW) NO UBUNTU OU LINUX MINT
    3. USANDO ITAÚ SEM O WARSAW
    4. O plugin de segurança que os bancos usam está causando problemas de acesso a alguns sites
    5. Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
    6. COMO INSTALAR E FAZER O GUARDIAO ITAU WARSAW FUNCIONAR NO CHROME 59 DO UBUNTU 16
  • Charlie: Initramfs

    Publicado em 16 de junho de 2017 omyasuda Sem comentários

    Não estava carregando o Calc do LibreOffice, então dei boot e caiu na tela

     

    Conforme indicado na mensagem de erro:

    fsck /dev/sda1

    seguido de uma série de autorizações para corrigir problemas encontrados, parece ter resolvido o problema.

    referencias:

    1. About initramfs – o básico sobre o initramfs.
    2. (INITRAMFS) [RESOLVIDO] – uma discussão no VivaoLinux sobre o assunto com idéias de solução.
  • Samba : Compartilhamento de Arquivos e Impressoras

    Publicado em 8 de junho de 2017 omyasuda Sem comentários

    Estas são as minhas anotações sobre a configuração e uso do Samba para compartilhamento de arquivos e impressoras em redes (o202 e LA181) mistas (Ubuntu e Windows (XP, Vista, Win8, etc)).

     

    referencias:

    1. Samba – home page
    2. File Server – documento base do samba no Ubuntu.
    3. Linux e Active Directory (Integrando COMPLETAMENTE sua estação Linux a um domínio MS Windows 2000/2003 Server)
    4. Samba 4 como controlador de domínio com Active Directory da MS

     

  • /var lotado

    Publicado em 11 de abril de 2017 omyasuda Sem comentários

    Começou com a ideia de manter a pasta /var em uma partição à parte, para tentar controlar o seu crescimento com o tempo. Mas, aos poucos foi mesmo virando um problema. Pois, ela ficando lotada, começa a impedir algumas operações em especial a atualização de alguns itens da minha instalação. Aqui algumas ideias que podem ser uteis.

     

    sudo apt-get update
    sudo dpkg –configure -a

     

    cd /var
    ls -la
    cd backups/
    ls -la
    sudo rm *.gz
    sudo rm *.bak
    cd ..
    ls
    sudo rm *.gz

    mover a pasta /var para algum outro lugar com um pouco mais de espaço, e criar um link simbolico para lá. Mas, como é que se continua depois. Voltamos a usar a pasta var em outra partição mesmo?? Deixamos lá? Dá para voltar para a partição restrita?

    mkdir ~/panic
    sudo cp -a /var/cache /home/omy/panic/cache
    rm -rf /var/cache
    sudo rm -rf /var/cache
    sudo ln -s /home/omy/panic/cache /var/cache

    BleachBit

    O BleachBit é uma ferramenta que pode ser usada nestes casos, para limpar a sua instalação de arquivos antigos que não são mais necessários. Ferramentas que automatizam processos devem ser usadas com cautela para evitar perdas por engano.

     

    which bleachbit
    sudo apt-get update
    sudo dpkg –configure -a
    sudo apt-get install bleachbit
    which bleachbit
    sudo bleachbit

     

    Referencias

    1. /var partition gets full what’s the solution? – um forum discutindo o assunto com idéias de trabalho.

     

     

     

     

  • Guardião Itaú (Warsaw) no Ubuntu

    Publicado em 19 de dezembro de 2016 omyasuda Sem comentários

    Bom…. mais uma vez, estou às voltas com o Guardião Itaú (Warsaw) aqui no meu desktop Ubuntu. Estas são as minhas anotações sobre mais este eventos.

    Aparentemente a última atualização do meu Mozilla Firefox desconfigurou o meu acesso ao Banco Itaú. De certa forma, isso está previsto entre as instruções de segurança no site do banco. Claro que poderia ser um pouco mais preciso e esclarecedor, mas vá lá!

    Neste meu desktop, o acesso ao Internet Banking do Itaú funcionava bem antes desta última atualização.

    Logo depois de fornecer Agencia e Conta, aparece o aviso de que estamos navegando sem o Guardião. Mas, conseguimos avançar, fornecendo a senha eletrônica. Transações que não precisam de autenticação maior como extrato são processadas normalmente. Mas, no caso do pagamento de boleto, o processo pede a instalação do Guardião.

    O processo de instalação baixar o arquivo warsaw_setup_64.deb e instalar com o Ubuntu Software termina normalmente, mas não é reconhecido no Mozilla Firefox.

    Uma rápida busca na internet, encontramos COMO INSTALAR O GUARDIÁO ITAÚ (WARSAW) NO UBUNTU OU LINUX MINT com as instruções detalhadas para a instalação do Guardião.

    sudo apt-get update
    sudo apt-get install libnss3-tools
    cd Downloads/
    sudo dpkg -i warsaw_setup_64.deb

    Aparentemente, as atualizações precisam ser complementadas com o libnss3-tools ! Precisei fechar e reabrir a sessão para que todo processo voltasse a funcionar normalmente.

    O App Itaú ainda parece não funcionar no desktop Ubuntu.

     

    ET: 2017-07-13 – Ainda com problemas na instalação do Guardião Itaú

    ~/Downloads$ sudo dpkg -i warsaw_setup_64.deb
    dpkg: acerca de warsaw_setup_64.deb contendo warsaw:
    diagbb conflita com warsaw
    warsaw (versão 1.3.0) está para ser instalado.

    dpkg: erro ao processar o arquivo warsaw_setup_64-i0.deb (–install):
    pacotes conflitantes – não instalando warsaw
    Erros foram encontrados durante o processamento de:
    warsaw_setup_64.deb

    Parece que é algum conflito com os recursos de segurança do Banco do Brasil.

    ET : 2017-03-22 – parece com problemas novamente. O site acusa que o Guardião não está instalado. Tentativas de instalar o guardião resultam em erro

    Getting CA Private Key
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_BAD_DATABASE: security library: bad database.
    Notice: Trust flag u is set automatically if the private key is present.
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_UNRECOGNIZED_OID: Unrecognized Object Identifier.
    Notice: Trust flag u is set automatically if the private key is present.

    O site de diagnóstico do Warsaw parece não achar o módulo e pede para instalar novamente.

    O site da GAS Tecnologia parece não estar no ar.

    A instalação do Guardião baixado no dia 19/03/2017, com 18.5 mb, instalou melhor e parece ter sido aceita pelo site que passou a indicar que o Guardião está instalado. A versão do pacote deb baixado hoje tem 3.5mb de tamanho. Estranho isso, não?

    ET : 2017-02-26 – Domingo de Carnaval. Por algum motivo, o Guardião Itaú não está sendo encontrado pelo site do Itaú e precisou ser reinstalado. As instruções do site do Itaú não foram suficientes, mas seguindo esta receita, tudo voltou a funcionar bem. Algumas coisas que não entendo:

    1. Porque este recurso se desatualiza (precisa ser reinstalado) neste ambiente?
    2. Porque o procedimento proposto pelo site não funciona?
    3. Porque é necessário o reboot após a instalação do WarSaw? Isso não é Ruindows!

    Referências:

    1. Itaú – site do Banco Itaú.
    2. COMO INSTALAR O GUARDIÁO ITAÚ (WARSAW) NO UBUNTU OU LINUX MINT – uma explicação bem completa sobre o procedimento a ser adotado para a instalação do guardião.
    3. F.A.Q. Suporte – informações adicionais sobre o Guardião desenvolvido pela GAS
  • Acesso ao banco do Brasil

    Publicado em 15 de julho de 2016 omyasuda Sem comentários

    Anotações sobre o acesso ao Banco do Brasil. Novamente, estamos às voltas com dificuldades para acessar os serviços de internet banking do Banco do Brasil (BB) em ambiente linux. Desta feita, com o Ubuntu 16.04 64 bits recem instalado. Continuar a ler este artigo »

  • Ubuntu 16.04 LTS Released

    Publicado em 24 de abril de 2016 omyasuda Sem comentários

    Bom, lá vamos nós com mais uma nova versão. Estas são as minhas anotações sobre este processo.

     

    Atualizar ou Reinstalar.

     

     

    Ambiente Gráfico

    Me voltou a questão de escolher entre os ambientes gráficos. Parece que esta escolha se deve a dificuldades que tive em instalações anteriores em parte por causa da placa gráfica nvidia. Na tela de login, clicando no icon no canto superior direito, as opções aparecem:

    Gnome compiz flashback

    Usa o compositor 3D para apresentar as janelas. Para aplicações que requerem melhor apresentação gráfica, esta é a opção recomendada.

    Gnome metacity flashback

    Exibe as janelas em 2D. Portanto, esta deve ser a sua opção para instalações com menor capacidade gráfica ou para economizar energia em dispositivos móveis.

    Para mim, por algum motivo ainda não esclarecido, a sessão é encerrada repentinamente voltando para a tela de login, durante a utilização, depois da atualização para 16.04.

    Ubuntu

    Nesta atualização, o ambiente Ubuntu está funcionando bem. Estou usando este.

    Referencias.

  • problemas com o ambiente gráfico

    Publicado em 27 de novembro de 2015 omyasuda Sem comentários

    Depois das últimas atualizações, o ambiente gráfico começou a apresentar problemas. Os problemas:

    1. o acesso a Configurações do Sistema não abre
    2. alguns programas não inicializam
    3. Captura de tela com alt-print-screen não está funcionando
    4. uvcvideo: UVC non compliance – GET_DEF(PROBE) not supported. Enabling workaround. – aparecendo no dmesg.

    Ambiente em Uso

    Config-details

    Sobre a minha configuração. Configurações do Sistema > Detalhes.

    Usando um terminal 

    ~$ sudo unity-control-center

    para ter acesso às Configurações do Sistema.

    A versão 15.10 é uma atualização da versão 15.04 instalada aqui anteriormente. Parece que este processo de atualização carrega “memória” da encarnação passada. Alternativamente, a instalação da nova versão parece trabalhosa, requerendo a configuração  dos aplicativos em uso.

    ~$ lspci | egrep “VGA|3D|Display”
    01:00.0 VGA compatible controller: NVIDIA Corporation G72 [GeForce 7200 GS / 7300 SE] (rev a1)

     

    sobre o driver de vídeo em uso.

     

    ~$ lsmod|grep nvidia
    ~$ lsmod|grep nouveau
    nouveau 1388544 3
    mxm_wmi 16384 1 nouveau
    wmi 20480 2 mxm_wmi,nouveau
    video 36864 1 nouveau
    i2c_algo_bit 16384 1 nouveau
    ttm 94208 1 nouveau
    drm_kms_helper 126976 1 nouveau
    drm 356352 6 ttm,drm_kms_helper,nouveau

    Parece que durante a alguma atualização o sistema tentou trocar o driver de video noveau (open source) pelo proprietário da nVidia. O que estaria causando o problema.

    Retornei a configurações do sistema > Programas e Atualizações > Drivers Adicionais para utilizar o driver open source Noveau.

    Reinstalei também a versão mais recente o Unity. As alternativas de desktop com os Gnome Flashback Compiz e Metacity também parece funcionar.

    ~$ sudo apt-get update
    ~$ sudo apt-get install –reinstall ubuntu-desktop
    ~$ sudo apt-get install –reinstall unity

    Reinicie a sessão (não foi necessário fazer reboot). Tudo parece estar funcionando novamente.

    O problema parece ter sido causado por fontes de programas configurados em configurações do sistema > Programas e Atualizações > Outros Programas que atualizaram e configuraram os recursos de ambiente gráfico e drivers de vídeo indevidamente. No momento, os painéis apontam:

    DriversAdcionais ProgramaseAtualizacoes

     

    Referencias:

    1. Solución al problema de Nvidia con Unity 3D en Ubuntu 12.04 – apesar de se referir a uma versão anterior do Ubuntu, traz as informações para o tratamento do problema.
    2. 10 Things To Do After Installing Ubuntu 15.10
    3. Ubuntu 15.10 Available to Download, This Is What’s New
    4. Ubuntu 15.10 nVidia Driver Problem – forum de discussão com problemas semelhantes aos que estou observando aqui.
    5. NVIDIA: how to install the latest video card drivers – orientações sobre os procedimentos para a instalação dos drivers de video da nVidia.
    6. No GUI after upgrade to Ubuntu 15.10 – um caso parecido com ideias de como atacar o problema.
  • Ubuntu 15.10 Wily Werewolf

    Publicado em 1 de novembro de 2015 omyasuda Sem comentários

    Anotações sobre o Wily Werewolf!

    Atualizar ou não?

    Não é LTS! Isso te incomoda? Não atualize! No mais, parece se uma boa medida.

    Para atualizar.

    http://www.edivaldobrito.com.br/atualizar-para-o-ubuntu-15-10/ – para atualizar o Desktop
    http://www.edivaldobrito.com.br/atualizar-para-o-ubuntu-15-10-server/ – Como atualizar para o Ubuntu 15.10 server

     

    Green

    É uma máquina grande que rodava Ubuntu 15.04 bem, sem apresentar maiores problemas. Quanto apareceu a sugestão de atualização pelo atualizador do Ubuntu aceitei e fez a atualização até o ponto do reboot. Mas não conseguiu rebootar. O que será que fiz de errado? Como deve ser o processo de atualização? Algum passo crítico no processo de atualização? Apesar desta máquina ser bem recente, ela já teve as suas encarnações Windows 8, Debian 7, e Ubuntu 15.04. Isso pode ter causado algum tipo de conflito.

    Aparentemente uma falha de configuração dos recursos UEFI não permitiam o boot do disco SSD. A tela aparecia preta com o cursos ( um grande X, aparentemente do UEFI) mas não consegui evoluir.

    Instalação a partir do DVD com o Ubuntu 15.10, tentando preservar a partição /home, não funcionou bem. Alguma configuração do desktop não ativou os paineis e menus. Até conseguia  fazer algumas coisas, mas não consegui levar a uma configuração usável.

    A reinstalação formatando a partição /home funcionou bem! Restaurei os dados de uma cópia preservada e tudo segue normal. Chato e ter de configurar as aplicações que uso novamente, como por exemplo o suporte a lingua chinesa com teclado e fontes.

    Depois de atualizar

     

    1. Dicas de coisas para fazer depois de instalar o Ubuntu 15.10 –
  • perde a configuração de teclado

    Publicado em 4 de setembro de 2015 omyasuda Sem comentários

    perdendo a configuração de teclado de sessão em sessão no Ubuntu 15.04 64bits.

     

    ~$ setxkbmap -model abnt2 -layout br

     

    Alem disso, a configuração das áreas de trabalho para aceitar configurações de teclado independentes preserva a configuração establecida com o comando acima.