Ícone RSS Ícone Página Principal
  • Debian 7

    Publicado em 11 de Fevereiro de 2014 omyasuda Sem comentários

    Instigado pelo MAC cá estou novamente experimentando. Desta feita com o Debian 7.3 64bits como o meu desktop. Na última hora, estou incluindo o Green neste processo. Será que o Charlie finalmente vai junto nesta?

    O Green é um ferro novo atualmente rodando Window 8, mas que está dando alguns problemas da validação. Vou tentar manter esta instalação em VirtualBox hospedado pelo Debian 7.3 64bits.

    Continuar a ler este artigo »

  • virada para o Slackware 14.0 x64 Desktop com KDE

    Publicado em 1 de Janeiro de 2013 omyasuda Sem comentários

    slackware logoKDE
    Estas são as minhas notas sobre a virada do meu desktop para o SlackWare 14.0 x64 com KDE. Já tínhamos este desejo de migrar para a distro SlackWare a algum tempo e agora surge a oportunidade. Na virada para o ano novo. O Ubuntu colocado sob suspeição. Alem disso estamos em boa companhia de amigos que migram comigo. Remando juntos fica mais fácil. Somente o Necessário! O Extraorinário é demais! (Balu, o Urso). É o lema que estaremos seguindo por aqui. Vamos fazer funcionar sem floreios. Estas notas estão sendo escritas enquanto faço a migração, portanto estão sujeitas a alterações repentinas. Alem disso, este texto não deve ser considerado sequencial. As notas estão sendo feitas de acordo com as suas proximidades de assunto. Sugiro a leitura de todo o texto antes de tentar seguir qualquer parte de procedimento citado aqui. Isso porque acredito que “Aprende-se”, mas “não se ensina!” Continuar a ler este artigo »

  • Slackware desktop

    Publicado em 16 de dezembro de 2012 omyasuda 1 comentário

    Estou me preparando para usar o Slackware 14.0 como meu desktop.

    Para isso, estou experimentando em VirtualBox seguindo o tutorial originalmente para o 12.0 em 11 partes. Um tanto longo, mas estou gostando pois é bem completo.

    Continuo escrevendo este texto enquanto continuo os meus exercícios de instalação e configuração do ambiente em VirtualBox. Procurarei anotar novamente estas observações em outra nota, quando for fazer a instalação definitiva do meu desktop. Projeto para a virada de ano. Continuar a ler este artigo »

  • SlackWare Experimentações antes de adotar como Desktop

    Publicado em 6 de Abril de 2012 omyasuda Sem comentários

    Procurando por uma alternativa de desktop ao Ubuntu, escolhi experimentar com o Slackware, inicialmente em VirtualBox, para ver se eu me adapto a ele.

     

    Referências

  • retomando o Squid no Debian em VirtualBox do meu Desktop….

    Publicado em 14 de julho de 2011 omyasuda Sem comentários

    Já estávamos com este trabalho parado a algum tempo…. mas, cá estamos de volta….

     

    ubuntu-logo VirtualBox Debian Squid
    A idéia é experimentar com o Squid em um Debian instalado em uma máquina VirtualBox em meu Desktop. Neste ambiente, experimentar os recursos de proxy, cache, etc.

     

     

    O primeiro problema que encontramos é que a configuração geral da máquina virtual se perdeu, restando somente a instalação em disco .vdi! Reinicando a máquina, ela funciona. Mas, qual era o IP desta máquina?

    ifconfig

    Sem privilégios, o comando não é executado.

    como root, depois de

    su

    Conseguimos ver os dados de IP e percebemos que ficou faltando configurar a placa de rede para o modo Bridge. Estava em modo NAT. Os paineis do VirtualBox ficam bloqueados se a maquina estiver Executando, mas a configuração nos paineis da máquina virtual permitem esta reconfiguração. Assim, conseguimos ver a configuração recebendo o endereço.

    No ifconfig só aparece a interface lo, porque ele não está conseguindo alocar a placa eth0. Isso porque no arquivo /etc/udev/rules.d/70-persistent-net.rules ainda temos o MAC da placa preservada pela configuração no arquivo .vdi. Limpando estes dados, a maquina consegue fazer uma busca entre os dispositivos e encontrar a placa eth0 para se comunicar com a rede.

    Ajustamos o router para redirecionar os acessos ssh (21 e 22) para a máquina Debian, com squid para os trabalhos do mundo exterior.

    Para iniciar esta máquina virtual no boot da máquina hospedeira, vamos colocar o comando

    nohup VBoxHeadless -startvm servername < /dev/null > /dev/null 2>&1 &

    no /etc/rc.local

     

  • uma nova instalação do Lucid Lynx

    Publicado em 29 de junho de 2010 omyasuda Sem comentários

    Estas são as minhas notas sobre uma nova instalação do Lucid Lynx em meu desktop pessoal. Este desktop tinha uma instalação de Lucid Lynx, na sua forma de atualização do Karmic Koala. Porque Reinstalar? Tenho observado dificuldades com alguns programas que entendo deveriam funcionar neste ambiente, mas podem estar sofrendo de problemas com a atualização:

    • sincronização do palm com o Evolution, aparentemente alguma coisa ficou mal configurada e não está funcionando.
    • o diretorio /home estava dentro da partição raiz, vou tentar separá-lo em uma partição distinta para facilitar as futuras reinstalações.
    • A conexão com a Internet tem caido intermitentemente, aparentemente algum tipo de conflito na configuração dos recursos da rede IP. Ainda pode ser algum problema de atualização dos navegadores mozilla e Chrome.

    Backup Backupearás!!! Lembrei de backupear

    • o diretório /home , com os arquivos pessoais dos usuários
    • as configurações do Evolution,
    • as pastas do Tomboy
    • das configurações de FTP do FileZilla.

    Do que me esqueci. Ainda não senti falta de nenhuma pasta. Deveria ter anotado as minhas configurações de audio. Tive algum trabalho para configurar corretamente os recursos de audio desta máquina. Instalação. Com o CD, a instalação é bem tranquila. No caso, tinha bem claro a distribuição das partições pelos meus discos físicos, por isso optei por um particionamento manual. No caso, de usar o particionamento básico, você não deve ter problemas tampouco. A escolha de uma senha para o seu usuário pode ser um tanto estressante, pois queremos que ela seja significativa e de razoável memorização. ais uma etapa vencida. Carregados os arquivos, fiz uma atualização geral do sistema com o Synaptics. Isso leva algum tempo pois o sistema tem que baixar as atualizações. Configuração dos diversos softwares do ambiente.

    • Mozilla – local de gravação dos downloads, tratamentos das senhas, página inicial. Instalação de complementos usuais como Downloadhelper, Firebug, ! Acesso o Youtube usando os recursos de Adobe Flash Player parece que funcionam bem agora. Tive que instalar os pacotes do produto, usando o Synaptics.
    • Office – desinstalando o OpenOffice para a instalação do BrOffice usando o Synaptics. O BrOffice tem implementado as especificações do Novo Acordo Ortográfico.

    Instalação do software de seu agrado.

    • Chrome –  navegador da Google, reconhecendo que os recursos Google (YouTube, BlogSpot, Wave, Docs, etc) funcionam melhor no Chrome, uso este navegador para atividades com estes produtos. "No inferno, abrace o diabo!" Download do arquivo .deb e instalação direta.
    • Opera – um navegador com um proxie embutido que está sendo útil no caso de acessos a sites bloqueados pelo Ajato.
    • ncftp – uma alternativa para as transferências de arquivos. Eu uso para fazer alguma automação nos backups de arquivos dos sites.
    • kmplayer – um player razoavelmente compativel com os recursos do mundo Microsoft. Tem funcionado bem.
    • VirtualBox – gerenciamento de máquina virtuais. As máquinas virtuais mantidas em disco separado continuam funcionando normalmente, nesta nova instalação do VirtualBox.
    • Gnome Pilot – conduit para sincronização do Palm com o Evolution, instalado e parece estar funcionando bem agora. Parece que o conflito está no compartilhamento dos recursos USB com o VirtualBox. Vamos usar isso em separado por enquanto.
    • FileZilla – o cliente de FTP que uso, instalado com o Synaptics, sem maiores dificuldades. Restaurando a pasta ~/.filezilla consegui obter as minhas configurações anteriormente utilizadas.
    • Skype – Voip que tenho usado… ainda tenho que verificar a questão da webcam que não funcionava anteriormente.
    • Python3 – tenho alguns programas desenvolvidos em Python3.
    • Kompozer – o meu editor HTML
    • Putty – o meu terminal TTY.
    • Seamonkey – um navegador que anteriormente vinha instalado.
    • gimp – manipulador de imagens que anteriormente vinha instalado.
    • geany – um pequeno IDE que uso para desenvolvimentos diversos.

    Ajustes de Configuração.

    • /etc/fstab – ajustando para a correta denominação dos discos adicionais de minha configuração.

    Restaurando os backups.

    • Evolution – restaurar o backup do Evolution foi realmente muito simples, seguindo-se os comandos do menu do produto. Foi necessário fornecer as senhas de acesso às contas de eMail novamente, mas isso me parece razoável.
    • Tomboy – copiando-se a pasta ~/.local/share/tomboy de volta todas as anotações voltaram para o meu desktop. Parece que isso precisa ser feito manualmente. Não encontrei uma sequencia no menu para isso. De qualquer forma, não é nada muito difícil.

    Acesso a outros micros da minha rede local. Tenho ainda alguns micros Windows em minha rede local. Na instalação anterior, tinha acesso às pastas compartilhadas nestes equipamentos. Agora parece que não. Verificando que os equipamentos ainda estavam na mesma sub-rede ip, isso parece estar normal. Como a instalação modificada foi esta, checando o compartilhamento de pastas em Sistema > Preferências > Compartilhamento de Pastas Pessoais, percebi que ele continha uma mensagem dizendo que faltava a instalação de alguns módulos. Reinstalei o Samba e o Swat ( sudo apt-get install samba swat ) . Reconfigurei o compartilhamento da pasta nesta instalação. Agora parece estar funcionando normalmente. Conforme a documentação consultada, cabe ainda confirmar nos outros equipamentos se as proteções de firewall e antivirus está permitindo o acesso aos arquivos compartilhados. Não observei mais os problemas de queda da conexão em minha rede local.

  • desktop parou de responder.

    Publicado em 14 de Maio de 2010 omyasuda Sem comentários

    mudei de Ubuntu 64 9.10 para 10.04 na semana passada. Não tive muito tempo para outras avaliações, tendo entrado na correria da preparação de uma apresentação….

    No meio da correria, me deparei com o desktop parando de responder. Clique com o mouse e nada… alguns comandos do teclado como o ctl-W fecha algumas telas. Com o Alt-Ctl-Del conseguir fazer um reboot. Temendo um desastre maior, coloquei um pendrive com Ubuntu 9.10 32bits na maquina….

    Como 32 bits tudo me pareceu normal. Naveguei um pouco mas voltei a rebootar para voltar para o meu novo Ubuntu 10.04. O HD do sistema parece não ter montado e cai na linha de comando do terminal. Por aqui, a montagem do disco me pareceu normal. Reboot.

    Agora o Ubuntu subiu normalmente. ou quase… procurei voltar as configurações de desktop para o mais default possivel, sem nenhuma animação ou outra firula qualquer. Depois de alguns instantes, os cliques do mouse começaram a ser ignorados pelo desktop…. Sem alternativa, alt-ctl-del e desliguei.

    Torquei o mouse por um reserva e religuei. Parece que está funcionando.