Ícone RSS Ícone Página Principal
  • Warsaw para o Itaú Internet Banking

    Publicado em 2 de setembro de 2017 omyasuda Sem comentários

    Ainda estou às voltas com o acesso ao Itaú Internet Banking no ambiente Ubuntu 17.04 64 bits.

    Um clique no botão “Instale agora” nos leva a página de download do arquivo warsaw_setup_64.deb sem maiores explicações ou alternativas.

    Prereqs

    No passado, a instalação do Guardião Itaú requeria os recursos do libnss3-tools e do libcurl3. Por via das certeza, procurei atualizar estas bibliotecas com:

    sudo apt-get update

    sudo apt-get install libnss3-tools libcurl3

    As mensagens resultantes indicam que estas bibliotecas estavam atualizadas e nada foi feito.

    Programas Ubuntu

    A instalação do arquivo baixado  warsaw_setup_64.deb usando o instalador Programas Ubuntu ( Ubuntu Software ) não teve sucesso, apesar de não apresentar mensagens de erro.

    Alternativamente, tentamos a instalação pela linha de comando, não sem antes limpar as instalações (e/ou tentativas anteriores), com

    sudo dpkg –purge warsaw

    sudo dpkg –install warsaw_setup_64.deb

    A desinstalação com purge pode parecer exagero, mas realmente encontra e retira configuração anteriores do pacote warsaw instalado. O que pode ser prudente.

    A instalação na linha de comando, apresenta as mensagens do processo de instalação. Incluindo a solicitação para sair do Mozilla Firefox para continuar com a instalação.

    Entre as mensagens durante a instalação

    Getting CA Private Key
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_BAD_DATABASE: security library: bad database.
    Notice: Trust flag u is set automatically if the private key is present.
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_BAD_DATABASE: security library: bad database.
    Notice: Trust flag u is set automatically if the private key is present.
    certutil: could not find certificate named “Warsaw Personal CA”: SEC_ERROR_UNRECOGNIZED_OID: Unrecognized Object Identifier.
    Notice: Trust flag u is set automatically if the private key is present.

    A presença destas mensagens não parecem impedir o progresso da instalação, mas causa um certo desconforto.

    Em alguns casos, ao final do processo de instalação, foi  necessário reiniciar o computador. Fato incomum para o ambiente Ubuntu.

    O acesso ao Bankline encontrou o Guardião devidamente instalado e funcionou bem no Mozilla Firefox 55.0.2 para 64bits. Mas, continua apresentando o mesmo problema nos navegadores Chrome e Chromium.

    Outras Perguntas

    1. O que acontece se ligarmos para o atendimento do Itaú pedindo ajuda com este problema? Um dia tentarei isso, mas se você já tiver experienciado isso, conte-nos!
    2. http://www.dieboldnixdorf.com.br/warsaw – O que é? O que faz? Ainda é necessário? Quando?
    3. http://www.gastecnologia.com/ – O que aconteceu com a GAS Tecnologia?
    4. Como fazer funcionar no Chrome e no Chromium? Ou outros navegadores?
    5. App Itaú no Computador – não tem para o sistemas operacionais Linux.

    Referencias:

    1. Como instalar o módulo de segurança do Banco Itaú no Linux
    2. COMO INSTALAR O GUARDIÁO ITAÚ (WARSAW) NO UBUNTU OU LINUX MINT
    3. USANDO ITAÚ SEM O WARSAW
    4. O plugin de segurança que os bancos usam está causando problemas de acesso a alguns sites
    5. Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
    6. COMO INSTALAR E FAZER O GUARDIAO ITAU WARSAW FUNCIONAR NO CHROME 59 DO UBUNTU 16
  • Scratch não roda no Mozilla Firefox do Ubuntu por falta de Java

    Publicado em 20 de agosto de 2010 omyasuda Sem comentários
    Scratch

    Scratch

    Uma linguagem visual muito interessantes, principalmente para ensino de programação para crianças, é o Scratch do MIT.

    Só que, não estava rodando no Mozilla Firefox do Ubuntu. Pedia para instalar o Java! Mas as receitas que estão no site do Java se referem a instalação do Java para o RedHat, nada falando sobre a instalação no Ubuntu. Tentativas de instalar com o binário, não apresentam erro, mas não carregam o plugin no Mozilla Firefox.

    Depois de bater um pouco a cabeça por ai, conseguimos (obrigado Marcos e Mauro pelo esforço na solução de mais este problema) a receita [1] que funcionou.

    sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”

    para incluir o repositório na sua lista

    sudo apt-get update

    para atualizar a sua list

    sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

    para instalar os pacotes java.

    java -version

    para conferir a versão do Java instalada.

    Pode ser preciso sair do Mozilla Firefox e entrar novamente para ver os plugins instalados. Digite na linha de endereços

    about:plugins

    Referências:

    1. http://www.ubuntugeek.com/how-install-sun-java-runtime-environment-jre-in-ubuntu-10-04-lucid-lynx.html – receita para a instalação do Java no Ubuntu para o Mozilla Firefox.